Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delay in Account Balance Update in Twilio Platform
Incident Report for Twilio
Resolved
The issue causing Account balance update delay in Twilio Platform has been rectified and Account balance is now being reflected real-time. This incident has been resolved.
Posted May 02, 2021 - 19:41 PDT
Monitoring
We are seeing recovery with the Account balance update delay in Twilio Platform. Account balance should now accurately reflect the correct real-time balance. We are monitoring the service for 30 minutes to ensure a full recovery.
Posted May 02, 2021 - 19:11 PDT
Update
We are experiencing Account balance update delay in Twilio Platform. A small subset of customers may not see account balance being reflected real-time. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 02, 2021 - 18:59 PDT
Investigating
Our monitoring systems have detected a potential issue with Twilio Billing product. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 02, 2021 - 18:38 PDT
This incident affected: TWILIO PLATFORM (Billing).