Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Connectivity Lost on ~7.7% of Super SIM Devices
      Incident Report for Twilio
      Resolved
      We will close the post on Twilio’s Status Page. If you have been impacted by this incident and wish to continue to receive updates, please open a ticket with customer support.
      Posted May 26, 2023 - 15:28 PDT
      Monitoring
      We are now seeing recovery of the previously reported connectivity issue. We are continuing to monitor for service stability. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 26, 2023 - 13:30 PDT
      Update
      We are still experiencing Super SIM connectivity issues where we're observing ~7.7% of active data sessions on Super SIM being dropped. Devices that attempted to reconnect immediately after losing connectivity should have been able to successfully reconnect to the redundant instances while the impacted one recovered. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 26, 2023 - 12:50 PDT
      Update
      Beginning at 6:32PM UTC, we observed ~7.7% of active data sessions on Super SIM being dropped. Devices that attempted to reconnect immediately after losing connectivity should have been able to successfully reconnect to the redundant instances while the impacted one recovered. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
      Posted May 26, 2023 - 11:55 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Super SIM. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 26, 2023 - 11:48 PDT