Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound Toll-Free SMS Delivery Delays to Verizon Network in US
Incident Report for Twilio
Resolved
We are no longer experiencing outbound Toll-Free SMS delivery delays to Verizon Network. This incident has been resolved.
Posted Oct 14, 2020 - 02:40 PDT
Monitoring
We are observing successful outbound Toll-Free SMS delivery delays to Verizon Network in the US 60 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 14, 2020 - 00:47 PDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2020 - 00:44 PDT
Update
We are experiencing outbound Toll-Free SMS delivery delays to Verizon Network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available
Posted Oct 13, 2020 - 23:43 PDT
Update
We are experiencing outbound Toll-Free SMS delivery delays to Verizon Network in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Oct 13, 2020 - 22:42 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 13, 2020 - 22:30 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).