We are no longer experiencing User Authentication Identity API High Latency for Verizon in United States. This incident has been resolved.
Posted Feb 24, 2026 - 06:11 PST
Update
We have observed a recovery in User Authentication Identity for Verizon in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 24, 2026 - 04:16 PST
Monitoring
We have observed a recovery in User Authentication Identity for Verizon in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 24, 2026 - 02:16 PST
Update
Twilio customers may be experiencing User Authentication Identity API high latency for Verizon in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 24, 2026 - 00:20 PST
Investigating
Twilio customers may be experiencing User Authentication Identity API high latency for Verizon in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.