Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Toll-Free SMS delivery degradation towards Verizon and T-Mobile, USA
Incident Report for Twilio
Resolved
This incident has been resolved
Posted 24 days ago. Sep 26, 2019 - 03:06 PDT
Investigating
We are observing SMS delivery degradation for Toll-Free SMS sent towards Verizon and T-Mobile handsets in the US. We are working with our carrier partners to resolve the issue. We will provide an update as soon as we have more information.
Posted 25 days ago. Sep 26, 2019 - 00:52 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).