Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Calls are Failing to South African DID's
Incident Report for Twilio
Resolved
Incoming Calls to South African DID's are connecting successfully. This incident is now resolved.
Posted May 14, 2020 - 13:02 PDT
Update
We are still experiencing call failures to South African DID's . Our engineers continue to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 14, 2020 - 11:49 PDT
Investigating
We are experiencing call failures to South African DID's . Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 14, 2020 - 09:03 PDT
This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).