Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delays to a subset of handsets in Venezuela
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 11 days ago. May 08, 2019 - 04:20 PDT
Update
This incident has been resolved.
Posted 11 days ago. May 08, 2019 - 02:40 PDT
Investigating
We have detected an increase in delivery delays for SMS sent to a subset of handsets in Venezuela. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 11 days ago. May 07, 2019 - 22:03 PDT
This incident affected: CARRIER NETWORK (SMS, Latin America).