Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics
        SMS Delivery Delays to Telefonica Network in Mexico
        Incident Report for Twilio
        Resolved
        We are no longer experiencing SMS delivery delays when sending messages to Telefonica network in Mexico. This incident has been resolved.
        Posted Jan 12, 2025 - 17:38 PST
        Investigating
        We are experiencing SMS delivery delays when sending messages to Telefonica network in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jan 12, 2025 - 16:38 PST
        This incident affected: CARRIER NETWORK (SMS, Latin America).