Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Ethio-Telecom in Ethiopia
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. This incident has been resolved.
      Posted Nov 29, 2022 - 22:39 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 20:39 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 16:09 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 12:26 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 29, 2022 - 10:36 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to Ethio-Telecom in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 29, 2022 - 09:36 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).