Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to US Carriers from a subset of Short-codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays when sending to US Carriers from a subset Twilio Short Codes. This incident has been resolved.
      Posted Jun 22, 2022 - 03:14 PDT
      Update
      We are observing recovery in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 22, 2022 - 01:14 PDT
      Monitoring
      We are observing recovery in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 23:15 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 19:30 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 15:30 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 21, 2022 - 13:35 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to US Carriers from a subset Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 21, 2022 - 12:39 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery report delays to US Carriers from a subset of Short-codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 21, 2022 - 12:33 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).