Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Delays in MMS delivery
Incident Report for Twilio
Resolved
Service is operating normally.
Posted about 2 months ago. May 06, 2017 - 17:44 PDT
Investigating
US & CA MMS messages are delayed up to 5 minutes. Shortcode MMS is not affected
Posted about 2 months ago. May 06, 2017 - 08:22 PDT
This incident affected: Programmable SMS (MMS).