Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays on Non-Domestic SMS Traffic to Egypt Vodafone
      Incident Report for Twilio
      Resolved
      In our investigation, we have identified that the issue of non-domestic SMS delivery delays to Vodafone network in Egypt shares a root cause with another active incident. We will mark this incident as resolved and continue reporting in the existing incident.
      Posted Jan 06, 2022 - 08:23 PST
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery delays to a subset of users when sending non-domestic messages to Vodafone network in Egypt. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 07:31 PST
      Update
      We are experiencing SMS delivery delays to a subset of users when sending non-domestic messages to Vodafone network in Egypt. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 05:30 PST
      Investigating
      We are experiencing SMS delivery delays to a subset of users when sending non-domestic messages to Vodafone network in Egypt. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 06, 2022 - 04:40 PST