Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Customers unable to download payment history receipt
      Incident Report for Twilio
      Resolved
      Service is operating normally.
      Posted Jan 29, 2016 - 19:40 PST
      Investigating
      We’re currently investigating an issue with customers not being able to download payment history receipts.
      Posted Jan 29, 2016 - 19:11 PST