Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Support page redirect to Sendgrid support
      Incident Report for Twilio
      Resolved
      The redirection behaviour is expected and the new process is 2-steps - first requiring a login here: https://support.twilio.com/access/normal before you go to the usual link to view your ticket history: https://support.twilio.com/hc/en-us/requests or https://support.twilio.com/hc/en-us/requests/organizations. This incident is resolved.
      Posted Feb 28, 2020 - 03:00 PST
      Update
      Twilio support and Authy help pages "https://support.twilio.com/hc/en-us/requests/" and "https://support.authy.com/hc/en-us/requests/" are redirecting to SendGrid support page. For any support issues please send an email to help@twilio.com. Our engineers are working on the issue to fix this as soon as possible. We will share more information as soon as they become available.
      Posted Feb 28, 2020 - 02:16 PST
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Feb 28, 2020 - 02:00 PST
      This incident affected: TWILIO PLATFORM (Customer Support Center).