Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Increased call failures when calling to and from numbers in Belgium.
Incident Report for Twilio
Resolved
All calls in Belgium are now connecting successfully.
Posted 4 months ago. Apr 05, 2019 - 10:58 PDT
Monitoring
Calls to and from numbers in Belgium are now connecting successfully. We will continue to monitor to ensure full recovery.
Posted 4 months ago. Apr 05, 2019 - 10:23 PDT
Update
We are continuing to observe increased failures when making calls from and to numbers in Belgium. Our engineers are working with our carrier partner to resolve this issue and we will update the status in another 60 minutes.
Posted 4 months ago. Apr 05, 2019 - 08:35 PDT
Update
We are still observing increased failures when making calls from and to numbers in Belgium. Our engineers are working with our carrier partner to resolve this issue and we will update the status in another 30 minutes.
Posted 4 months ago. Apr 05, 2019 - 07:54 PDT
Update
We have observed increased failures in both receiving and making calls in Belgium. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 4 months ago. Apr 05, 2019 - 07:14 PDT
Investigating
We have detected an increase in failures for receiving calls to some Twilio phone numbers in Belgium. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 4 months ago. Apr 05, 2019 - 07:04 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).