Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to US Cellular Network via a Subset of Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery report delays when sending to US Cellular Network via a Subset of Short Codes. This incident has been resolved.
      Posted Sep 23, 2021 - 16:00 PDT
      Monitoring
      We are observing recovery in delivery report delays when sending to US Cellular network via a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 23, 2021 - 15:00 PDT
      Update
      We are experiencing delays in receiving message delivery reports when sending to US Cellular Network on a subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 23, 2021 - 14:00 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS Delivery Report Delays to US Cellular Network via a subset of short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 23, 2021 - 13:58 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).