Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Entel Network in Peru
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Entel Network in Peru. This incident has been resolved.
      Posted Nov 23, 2022 - 18:56 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to the Entel network in Peru. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 23, 2022 - 17:14 PST
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to the Entel network in Peru. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 23, 2022 - 16:44 PST
      Update
      We are continuing to experience delays in receiving message delivery reports when sending to the Entel network in Peru. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 23, 2022 - 14:20 PST
      Update
      We are experiencing delays in receiving message delivery reports when sending to the Entel network in Peru. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 23, 2022 - 13:24 PST
      Update
      We are experiencing delays in receiving message delivery reports when sending to the Entel network in Peru. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 23, 2022 - 13:24 PST
      Investigating
      Our monitoring systems have detected a potential issue with Entel network in Peru. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 23, 2022 - 13:17 PST
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks) and PROGRAMMABLE MESSAGING (SMS).