Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound SMS Delivery delays - US and Canada
      Incident Report for Twilio
      Resolved
      All services are operating normally.
      Posted Oct 22, 2018 - 16:38 PDT
      Update
      At the moment we are no longer observing delays to SMS delivery. Our engineering team is investigating the earlier issues. We will post another update as we have more information.
      Posted Oct 22, 2018 - 16:17 PDT
      Update
      We are also observing delivery delays for inbound SMS from some Canadian phone numbers.
      Posted Oct 22, 2018 - 15:24 PDT
      Update
      We are experiencing inbound SMS delivery delays to some US phone numbers (long codes) and some US short codes. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
      Posted Oct 22, 2018 - 12:14 PDT
      Investigating
      We are experiencing delays in the delivery of inbound SMS messages on some US short codes. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
      Posted Oct 22, 2018 - 11:12 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).