Latency in responses with AI chatbots and contacting support has been resolved and AI chatbots in the Twilio and SendGrid Help Centers is operating normally at this time
Posted Mar 09, 2026 - 22:24 PDT
Monitoring
AI chatbots in the Twilio and SendGrid Help Centers are now operating normally. We will continue to monitor for system stability. We'll provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 09, 2026 - 21:22 PDT
Update
AI chatbots in the Twilio and SendGrid Help Centers are now operating normally. We will continue to monitor for system stability. We'll provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 09, 2026 - 21:21 PDT
Identified
We have identified the issue and currently Twilio and SendGrid customers are experiencing elevated latency of ~1 minute to 2.5 minutes in responses with AI chatbots and contacting support. Our engineers are actively working to deploy the fix. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted Mar 09, 2026 - 20:51 PDT
Update
We are continuing to investigate reports of Twilio and SendGrid customers experiencing issues with AI chatbots and contacting support. Our engineers are actively working to identify the root cause. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 09, 2026 - 20:13 PDT
Update
We are continuing to investigate reports of Twilio and SendGrid customers experiencing issues with AI chatbots and contacting support. Our engineers are actively working to identify the root cause. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 09, 2026 - 18:07 PDT
Update
We are continuing to investigate reports of Twilio and SendGrid customers experiencing issues with AI chatbots and contacting support. Our engineers are actively working to identify the root cause. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 09, 2026 - 17:10 PDT
Update
We are continuing to investigate reports of Twilio and SendGrid customers experiencing issues with AI chatbots and contacting support. Our engineers are actively working to identify the root cause. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 09, 2026 - 16:40 PDT
Update
Twilio and SendGrid customers may be experiencing issues interacting with AI chatbots in our Help Centers. Customers may not be able to speak with AI Chatbot in Twilio Help Center and SendGrid Help Center. Some customers may not be able to contact Twilio Support. Our engineers have been alerted and are investigating the root cause. We expect to provide another update in 15 minutes or as soon as more information becomes available.
Posted Mar 09, 2026 - 16:25 PDT
Investigating
Our monitoring systems have detected a potential issue with AI chatbots in the Twilio and SendGrid Help Centers. Our engineers have been alerted and are investigating. We will provide an update when we have more details
Posted Mar 09, 2026 - 15:54 PDT
This incident affected: TWILIO PLATFORM (Customer Support Center).