Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Duplicate inbound messages to Twilio phone numbers
      Incident Report for Twilio
      Resolved
      The service is operating normally at this time.
      Posted Oct 01, 2015 - 17:03 PDT
      Identified
      We have verified that some old inbound messages longer than 140 bytes are having duplicate messages redelivered to Twilio numbers.
      Posted Oct 01, 2015 - 15:21 PDT
      Investigating
      We are investigating reports of duplicate inbound messages being delivered to Twilio phone numbers.
      Posted Oct 01, 2015 - 14:15 PDT