Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Scoped Phone Number Filtering Endpoints Not Returning Filtered Results
      Incident Report for Twilio
      Resolved
      The issue with appropriate filtering to the affected endpoints namely /IncomingPhoneNumbers/TollFree, /IncomingPhoneNumbers/Local, and /IncomingPhoneNumbers/Mobile are now fixed and phone numbers service is operating normally at this time. This incident is now resolved.
      Posted Aug 05, 2020 - 19:38 PDT
      Update
      Our team has deployed a fix to restore functionality to the three impacted endpoints. We are actively monitoring and an additional update will be provided in the next 30 minutes
      Posted Aug 05, 2020 - 19:22 PDT
      Update
      Our team has deployed a fix to restore functionality to the three impacted endpoints. We are actively monitoring and an additional update will be provided in the next 30 minutes
      Posted Aug 05, 2020 - 18:51 PDT
      Update
      Our team has deployed a fix to restore functionality to the three impacted endpoints. We are actively monitoring and an additional update will be provided in the next 30 minutes
      Posted Aug 05, 2020 - 18:21 PDT
      Monitoring
      Our team has deployed a fix to restore functionality to the three impacted endpoints. We are actively monitoring and an additional update will be provided in the next 30 minutes.
      Posted Aug 05, 2020 - 17:51 PDT
      Identified
      Our team has identified the problem issue causing the three endpoints to return incorrect filtering results. We are actively working to restore the functionality and an additional update will be provided in the next two hours.
      Posted Aug 05, 2020 - 15:52 PDT
      Update
      Our team has identified three impacted endpoints; /IncomingPhoneNumbers/TollFree, /IncomingPhoneNumbers/Local, and /IncomingPhoneNumbers/Mobile. API calls to these endpoints will not return the appropriate filtering, instead returning all phone numbers. The default /IncomingPhoneNumbers endpoint works as expected. We continue to investigate, and an additional update will be provided in the next 60 minutes.
      Posted Aug 05, 2020 - 14:54 PDT
      Update
      Our team has identified three impacted endpoints; /IncomingPhoneNumbers/TollFree, /IncomingPhoneNumbers/Local, and /IncomingPhoneNumbers/Mobile. API calls to these endpoints will not return the appropriate filtering, instead returning all phone numbers. The default /IncomingPhoneNumbers endpoint works as expected. We continue to investigate, and an additional update will be provided in the next 30 minutes.
      Posted Aug 05, 2020 - 14:28 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 05, 2020 - 14:16 PDT
      This incident affected: PHONE NUMBERS.