Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Lleida Spain
      Incident Report for Twilio
      Resolved
      Service has been restored fully. This incident is resolved.
      Posted Jan 27, 2021 - 05:21 PST
      Monitoring
      We are observing signs of recovery of service. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 27, 2021 - 04:44 PST
      Investigating
      We are experiencing delivery failures, sending to and receiving from Spain Lleida subscribers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 27, 2021 - 04:23 PST
      This incident affected: CARRIER NETWORK (SMS, Europe).