Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Asiacell in Iraq
Incident Report for Twilio
Resolved
The incident of SMS delivery delays to Asiacell in Iraq is now resolved.
Posted Jun 24, 2020 - 12:00 PDT
Monitoring
We are seeing recovery on the messages submitted to to Asiacell in Iraq. We will continue to monitor and provide further update if needed.
Posted Jun 24, 2020 - 00:16 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 22, 2020 - 23:09 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 21, 2020 - 23:00 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 20, 2020 - 20:06 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 19, 2020 - 23:00 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 18, 2020 - 23:01 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 17, 2020 - 23:04 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 17, 2020 - 16:02 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 17, 2020 - 08:14 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 17, 2020 - 04:09 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 17, 2020 - 02:08 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Asiacell in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 17, 2020 - 01:08 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).