Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Black Friday / Cyber Monday Alert

        Incident Report for Twilio

        Resolved

        The issue affecting traffic on US and Canada networks has been resolved, and the service is functioning normally at this time.
        Posted Nov 27, 2023 - 17:47 PST

        Investigating

        Due to increased traffic demand on mobile communication networks, we will expect potential congestion for US carrier networks during the Black Friday and Cyber Monday period. Customers may experience intermittent SMS and MMS delivery delays. Please refer to our Black Friday / Cyber Monday FAQ page, in the Help Center on Twilio.com, for more information.
        Posted Nov 23, 2023 - 15:01 PST