Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      A Subset of Non-Beta Customers Unable to View Interconnect Connections in Console
      Incident Report for Twilio
      Resolved
      The issue with viewing Interconnect Connections in the Console has been resolved.
      Posted Apr 12, 2021 - 09:51 PDT
      Monitoring
      The Interconnect Connections view in the Twilio Console is now operational. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted Apr 12, 2021 - 09:21 PDT
      Investigating
      We are currently investigating an issue with a subset of non-beta customers unable to view their Interconnect connections in the Twilio Console. Traffic via Interconnect is not impacted. Our engineers are working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
      Posted Apr 12, 2021 - 08:31 PDT
      This incident affected: INTERCONNECT.