Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Toll Free SMS Delivery Delays to and from T-Mobile US handsets
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 25 days ago. Aug 30, 2019 - 03:13 PDT
Identified
We are experiencing delays in delivering and receiving SMS messages to and from Toll Free numbers to and from T-Mobile US handsets, due to ongoing operator maintenance. We expect the maintenance to be completed by 30 August 03:00 PDT.
Posted 25 days ago. Aug 29, 2019 - 23:57 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).