Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays to AT&T Network in the US
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery delays to AT&T network in the US over a subset of short codes & toll free numbers. This incident has been resolved.
      Posted Aug 02, 2022 - 17:45 PDT
      Monitoring
      We are observing recovery in MMS delivery delays to AT&T network in the US over a subset of short codes & toll free numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 15:46 PDT
      Update
      We continue experiencing MMS delivery delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 11:47 PDT
      Update
      We are still experiencing MMS delivery delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 02, 2022 - 09:47 PDT
      Investigating
      We are experiencing MMS delivery delays to multiple networks in US over a subset of Short Codes & Toll Free Numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 02, 2022 - 08:59 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America, MMS Toll-Free, SMS Delivery Notifications & Status Callbacks).