Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays for Sent and Received WhatsApp Messages
Incident Report for Twilio
Resolved
We are no longer experiencing delays of sent and received WhatsApp messages. The queues have cleared and all systems are operating normally. This incident has been resolved.
Posted May 19, 2021 - 15:20 PDT
Update
We continue to observe recovery of sending and receiving messages via the WhatsApp Business API starting at 2:16PM Pacific Time. The queued messages continue to be processed. We will continue to monitor the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted May 19, 2021 - 14:55 PDT
Monitoring
We are observing recovery of sending and receiving WhatsApp messages. The queued messages are now being processed. We will continue to monitor the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted May 19, 2021 - 14:28 PDT
Update
We continue experiencing delays for both sent and received WhatsApp messages for a subset of customers. Our engineers have identified the issue and continue working to resolve it. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 19, 2021 - 13:45 PDT
Update
We continue experiencing delays for both sent and received WhatsApp messages for a subset of customers. Our engineers have identified the issue and continue working to resolve it. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 19, 2021 - 12:50 PDT
Identified
We are experiencing delays for both sent and received WhatsApp messages for a subset of customers. Our engineers have identified the issue and are working to resolve it. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 19, 2021 - 12:13 PDT
Investigating
Our monitoring systems have detected a potential issue with WhatsApp. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 19, 2021 - 12:05 PDT
This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).