Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Kyivstar, Ukraine
Incident Report for Twilio
Resolved
The operator has confirmed that they have resolved the issue causing SMS delivery delays to their network. We are now observing full and stable recovery for SMS sent to Kyivstar, Ukraine.
Posted 2 months ago. Jan 09, 2019 - 03:54 PST
Investigating
We are observing SMS delivery delays for SMS sent to the Kyivstar network in Ukraine. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 2 months ago. Jan 08, 2019 - 23:17 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).