Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Intermittent Connection Issues Logging in and Using Flex
Incident Report for Twilio
Resolved
The external issue causing Flex Agent Desktop issues has been resolved, and the service is functioning normally at this time.
Posted Jul 12, 2021 - 11:27 PDT
Update
A fix has been implemented by the external network provider, and we are now observing recovery for the Flex related issues. We will continue monitoring to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 09:27 PDT
Monitoring
A fix has been implemented by the external network provider, and we are now observing recovery for the Flex related issues. We will continue monitoring to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 09:21 PDT
Identified
The incident causing intermittent Flex connection errors has been identified to be related to an external network issue, impacting mostly customers in Poland and UK. We are actively working with our network provider to resolve this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 08:34 PDT
Update
We are still experiencing an intermittent issue where Flex agents using Flex Agent Desktop are unable to login, fetch Flex configuration, and connect to Twilio SDKs. Our engineers continue working to resolve this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 06:26 PDT
Update
We are aware of an issue, wherein Flex agents using Flex Agent Desktop may be experiencing issues logging in, fetching Flex configuration and connecting to Twilio SDKs. Our engineers are working to resolve this issue. We expect to provide another update in 1 hour, or as soon as more information becomes available.
Posted Jul 12, 2021 - 05:28 PDT
Investigating
We've become aware of a potential issue with Twilio Flex. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 12, 2021 - 05:03 PDT
This incident affected: FLEX (Flex Application Platform).