Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound SMS for a high percentage of Messages are currently delayed
      Incident Report for Twilio
      Resolved
      All services are operating normally now.
      Posted Aug 15, 2017 - 11:09 PDT
      Monitoring
      We are seeing recovery across Inbound SMS message delivery times. Our engineers will continue to monitor our systems.
      Posted Aug 15, 2017 - 10:19 PDT
      Update
      We are continuing to investigate delays on inbound message delivery. US and CA are impacted, other destinations are not impacted.
      Posted Aug 15, 2017 - 09:55 PDT
      Update
      We are continuing to investigate delays in inbound message delivery of up to 15 minutes.
      Posted Aug 15, 2017 - 09:36 PDT
      Investigating
      We are currently experiencing an issue with delayed Inbound Delivery for SMS, this is affecting all countries we support.
      Posted Aug 15, 2017 - 09:18 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (MMS, SMS).