Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays subset of US Short Code
Incident Report for Twilio
Resolved
The MMS delivery delays over US short codes towards Verizon and Sprint is now resolved. MMS is operating normally at this time.
Posted 7 months ago. Jan 30, 2019 - 21:16 PST
Monitoring
We are observing recovery in short code MMS latency for outbound and inbound messages over short codes towards Verizon and Sprint. We will continue to monitor and work with our carrier partners to confirm the issue is fully resolved.
Posted 7 months ago. Jan 30, 2019 - 21:04 PST
Investigating
We are observing delays in delivering outbound and inbound MMS over a subset of US Short Codes towards Verizon and Sprint. We are actively working with our carrier partners to get the issues resolved.
Posted 7 months ago. Jan 30, 2019 - 13:24 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).