Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Number Verification Call Failures During Hosted Number Orders in the Console
      Incident Report for Twilio
      Resolved
      The issue affecting caller ID verification in the Console has been resolved, and the service is functioning normally at this time.
      Posted Sep 20, 2022 - 17:47 PDT
      Update
      We continue to investigate verification call failures for hosted number orders. Verification calls can be bypassed temporarily by uploading a copy of the bill dated within 30 days with the numbers listed. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 20, 2022 - 13:46 PDT
      Update
      We continue to investigate verification call failures for hosted number orders. Verification calls can be bypassed temporarily by uploading a copy of the bill dated within 30 days with the numbers listed. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 20, 2022 - 11:46 PDT
      Update
      We are currently investigating verification call failures for hosted number orders. Verification calls can be bypassed temporarily by uploading a copy of the bill dated within 30 days with the numbers listed. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 20, 2022 - 10:47 PDT
      Investigating
      We've become aware of a potential issue with caller ID verification in the Console. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 20, 2022 - 10:12 PDT