Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Events Streams Are Delayed
Incident Report for Twilio
Resolved
Event Stream delays have been resolved and is operating normally at this time.
Posted Nov 19, 2020 - 21:39 PST
Monitoring
Event Stream delays observed in Notify, Authy 2FA and Flex Insights are now operating normally. We will continue to monitor the situation before we mark the incident as fully resolved.
Posted Nov 19, 2020 - 21:27 PST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2020 - 20:40 PST
Update
We are addressing the issue where Event Streams are delayed. We expect another update in 60 minutes.
Posted Nov 19, 2020 - 20:09 PST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2020 - 19:41 PST
Investigating
Our monitoring systems have detected a potential issue with Authy 2FA. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 19, 2020 - 19:34 PST
This incident affected: AUTHY (Authy 2FA), FLEX (Flex Insights), and PROGRAMMABLE MESSAGING (Notify).