Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay To Al-Madar Libya
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays to Al-Madar network in Lybia.
      Posted Dec 05, 2021 - 09:01 PST
      Update
      We continue observing recovery in SMS delivery delays when sending messages to Al-Madar network in Lybia. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 05, 2021 - 07:50 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Al-Madar network in Lybia. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 05, 2021 - 05:54 PST
      Update
      We are still experiencing SMS delivery delays to Al-Madar network in Lybia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 8 hours or as soon as more information becomes available.
      Posted Dec 05, 2021 - 01:10 PST
      Update
      We are still experiencing SMS delivery delays to Al-Madar network in Lybia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 4 hours or as soon as more information becomes available.
      Posted Dec 04, 2021 - 21:10 PST
      Update
      We are still experiencing SMS delivery delays to Al-Madar network in Lybia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 2 hours or as soon as more information becomes available.
      Posted Dec 04, 2021 - 19:14 PST
      Update
      We are experiencing SMS delivery delays to Al-Madar network in Lybia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
      Posted Dec 04, 2021 - 18:20 PST
      Investigating
      We are experiencing SMS delivery delays to Al-Madar network in Lybia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
      Posted Dec 04, 2021 - 18:19 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).