Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays on AT&T and T-Mobile
Incident Report for Twilio
Resolved
We are no longer experiencing delays in delivery of MMS messages to AT&T and T-Mobile network. This incident has been resolved.
Posted Nov 19, 2021 - 05:26 PST
Monitoring
We are observing recovery in delivery of MMS messages to AT&T and T-Mobile network. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 19, 2021 - 03:35 PST
Update
We are continuing to work with our carrier partner to resolve MMS delivery delays sending to AT&T and T-Mobile Networks. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 19, 2021 - 02:20 PST
Update
We are continuing to work with our carrier partner to resolve MMS delivery delays sending to AT&T and T-Mobile Networks. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 18, 2021 - 18:22 PST
Update
We are continuing to work with our carrier partner to resolve MMS delivery delays sending to AT&T and T-Mobile Networks. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 18, 2021 - 14:22 PST
Update
We are continuing to work with our carrier partner to resolve MMS delivery delays sending to AT&T and T-Mobile Networks. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 18, 2021 - 12:22 PST
Investigating
We are observing delays in delivery of MMS messages to AT&T and T-Mobile network. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 Hour or as soon as more information becomes available.
Posted Nov 18, 2021 - 11:22 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America).