Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Email Delivery Delays Impacting Multiple Services
Incident Report for Twilio
Resolved
The issue resulting in email delivery delays across multiple Twilio products has been resolved.
Posted Jul 28, 2020 - 15:15 PDT
Update
The issue resulting in email delivery delays across multiple Twilio products has been resolved. The systems are now operating normally. We are continuing to monitor the situation before we mark the incident as fully resolved.
Posted Jul 28, 2020 - 13:22 PDT
Monitoring
The issue resulting in email delivery delays across multiple Twilio products has been resolved. The systems are now operating normally. We will continue to monitor the situation before we mark the incident as fully resolved.
Posted Jul 28, 2020 - 12:18 PDT
Identified
We have identified the source of the issue that resulted in email delivery delays across multiple Twilio products. While our team continues to work on a full resolution, we are seeing stable performance in email delivery in the past 30 minutes and will provide an update as soon as more information becomes available.
Posted Jul 28, 2020 - 12:00 PDT
Update
We continue to investigate the issue of email delivery delays across multiple Twilio products. Transactional emails from Twilio and Authy, as well as emails generated with Twilio Verify API, are all potentially delayed. We will provide another update as soon as we have more information.
Posted Jul 28, 2020 - 11:13 PDT
Update
We are currently experiencing an email outage resulting in missing emails from multiple Twilio products. As a result, Twilio users are not receiving debugger alert emails, password resets, and verification emails. Authy users can not initiate a phone change or account recovery. We are actively investigating the issue and will provide an update as soon as we have additional information.
Posted Jul 28, 2020 - 10:08 PDT
Investigating
Our monitoring systems have detected a potential issue affecting Twilio Verify. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 28, 2020 - 09:39 PDT
This incident affected: AUTHY (Authy 2FA, Verify) and TWILIO PLATFORM (Debugger & Alerts, Console).