Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US SMS Delivery Report Delays Over US Shortcodes
Incident Report for Twilio
Resolved
We are no longer experiencing delays in receiving delivery reports of SMS sent to US handsets over a subset of US shortcodes. This incident has been resolved.
Posted Sep 15, 2020 - 21:20 PDT
Monitoring
We are observing recovery in delivery report delays of SMS sent to US handsets over a subset of US shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Sep 15, 2020 - 20:21 PDT
Update
We are still observing delays in receiving delivery reports of SMS sent to US handsets over a subset of US shortcodes. We are working with our carrier partners to resolve the issue and will provide an update in 2 hours or as soon as we have more information.
Posted Sep 15, 2020 - 20:16 PDT
Investigating
We are observing delays in receiving delivery reports of SMS sent to US handsets over a subset of US shortcodes. We are working with our carrier partners to resolve the issue and will provide an update in 1 hour or as soon as we have more information.
Posted Sep 15, 2020 - 19:20 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).