Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound Call Failures to Phone Numbers in France and Estonia
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 15, 2019 - 04:01 PST
      Investigating
      We are observing increased call failures for calls made towards Twilio phone numbers in Estonia and France. Our engineers are working with our provider to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Nov 15, 2019 - 03:39 PST
      This incident affected: CARRIER NETWORK (Voice, Europe).