Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS/MMS Short Code Delivery Delays to/from Sprint US
Incident Report for Twilio
Resolved
We are no longer experiencing Shortcode SMS/MMS delivery delays to Sprint US. This incident has been resolved.
Posted Jul 25, 2020 - 13:20 PDT
Identified
We have identified messaging delivery delays for our Shortcode SMS/MMS submitted to and from Sprint in the USA. We show some sign of recovery and are continuing to work with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Jul 25, 2020 - 11:38 PDT
Update
We are observing messaging delivery issues for our Shortcode SMS/MMS submitted to and from Sprint in the USA. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Jul 25, 2020 - 10:31 PDT
Update
We are experiencing SMS/MMS delivery delays to and from Sprint US via Twilio Short Codes. We are working with our carrier partners to resolve this issue. We will provide further updates, as they become available.
Posted Jul 25, 2020 - 09:21 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 25, 2020 - 09:15 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America, MMS Short Code, North America).