Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Caller Name Lookups Failing via Console and API
      Incident Report for Twilio
      Resolved
      We have continued to see successful Caller Name Lookups since 7:10 AM PST. The service is fully operational, and this incident is resolved.
      Posted Mar 05, 2021 - 07:59 PST
      Monitoring
      We are now seeing successful Caller Name Lookups since 7:10 AM PST. We will continue to monitor to ensure full service recovery and will provide an update in the next 30 minutes.
      Posted Mar 05, 2021 - 07:29 PST
      Update
      We are now seeing successful Caller Name Lookups since 7:10 AM PST. We will continue to monitor to ensure full service recovery and will provide an update in the next 30 minutes.
      Posted Mar 05, 2021 - 07:27 PST
      Update
      We are currently investigating a degradation to our Lookup API in which caller name lookups are failing via API and Console. All other lookups including Carrier Name are still working as expected. The API has been degraded since 6:41 AM Pacific Time and our engineers are actively investigating to identify the cause. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 05, 2021 - 07:13 PST
      Investigating
      Our monitoring systems have detected a potential issue with Caller Name Lookups via Console and API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 05, 2021 - 06:59 PST
      This incident affected: TWILIO PLATFORM (Other).