Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Receipt Delays When Sending to T-Mobile Network in US
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery report delays when sending MMS to T-Mobile network in US. This incident has been resolved.
      Posted Sep 13, 2022 - 23:32 PDT
      Monitoring
      We are observing recovery in delivery report delays when sending MMS to T-Mobile network in US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 21:36 PDT
      Update
      We are experiencing delays in receiving message delivery receipts when sending MMS to T-Mobile network in US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 13, 2022 - 20:36 PDT
      Investigating
      Our monitoring systems have detected a potential issue with MMS delivery receipts delays to T-Mobile network in US. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 13, 2022 - 20:28 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).