Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS and MMS Latency for a Subset of Twilio Customers
Incident Report for Twilio
Resolved
We are no longer experiencing latency when sending MMS and SMS. This incident has been resolved.
Posted Dec 01, 2021 - 10:38 PST
Monitoring
We are observing recovery with SMS and MMS latency when sending to US and Canadian networks. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 mins or as soon as more information becomes available.
Posted Dec 01, 2021 - 10:10 PST
Update
We are experiencing elevated SMS and MMS latency when sending to US and Canadian networks for a small subset of Twilio customers. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 01, 2021 - 09:55 PST
Investigating
Our monitoring systems have detected a potential issue with high latency for MMS sending. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Dec 01, 2021 - 09:35 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS).