Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Movilnet in Venezuela
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays to Movilnet in Venezuela. This incident has been resolved.
Posted Jun 20, 2020 - 13:24 PDT
Monitoring
We are observing successful SMS delivery to Movilnet in Venezuela. We will continue to monitor to ensure a full recovery.
Posted Jun 20, 2020 - 11:32 PDT
Update
We are continuing to investigate this issue.
Posted Jun 20, 2020 - 10:13 PDT
Update
We are experiencing SMS delivery delays when sending messages to Movilnet Venezuela. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 20, 2020 - 09:00 PDT
Investigating
We are observing message delivery issue for our messages submitted to Movilnet in Venezuela. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Jun 20, 2020 - 08:46 PDT
This incident affected: CARRIER NETWORK (SMS, Latin America).