Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Payment Processor Outage Preventing Funding of non-invoiced Accounts
Incident Report for Twilio
Resolved
We are no longer experiencing errors with PayPal payment processing. This incident has been resolved.
Posted Sep 16, 2020 - 10:50 PDT
Monitoring
We are observing successful payment processing via PayPal since 9:45am PT. We will continue to monitor to ensure full recovery of the service. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 16, 2020 - 10:23 PDT
Investigating
We are experiencing a higher level of errors with PayPal payment processing due to an ongoing incident at our payment processor and all PayPal transactions are failing. Please use credit cards for adding funds to your Twilio account while it is being investigated and resolved.
Posted Sep 16, 2020 - 09:39 PDT
This incident affected: TWILIO PLATFORM (Billing).