Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures to Non-US numbers
Incident Report for Twilio
Resolved
After monitoring the situation, we are now seeing full recovery of SMS delivered to non-US numbers
Posted Feb 13, 2020 - 06:46 PST
Monitoring
We are beginning to see SMS delivery recover, and are continuing to closely monitor the situation. We will provide further updates in due course.
Posted Feb 13, 2020 - 05:56 PST
Update
We are continuing to investigate this issue
Posted Feb 13, 2020 - 03:23 PST
Update
We are continuing to investigate this issue with our carrier partner
Posted Feb 13, 2020 - 01:43 PST
Investigating
We are experiencing delivery failures sending to Non-US numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Feb 13, 2020 - 00:25 PST
This incident affected: CARRIER NETWORK (SMS, Latin America, SMS, APAC, SMS, Europe, SMS, Middle East & Africa).