Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures to MTN, Nigeria
Incident Report for Twilio
Resolved
Delivery to the MTN network in Nigeria has been restored. The service is operating normally.
Posted 13 days ago. Mar 11, 2019 - 04:02 PDT
Monitoring
We are observing recovery in SMS delivery to the MTN network in Nigeria and will continue to monitor the service.
Posted 13 days ago. Mar 11, 2019 - 03:52 PDT
Investigating
We have detected an increase in delivery failures for SMS sent to the MTN network in Nigeria. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 13 days ago. Mar 10, 2019 - 22:03 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).