Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays from Subset of Twilio Short Codes to US Sprint
Incident Report for Twilio
Resolved
We are no longer experiencing delivery failures for Short Codes to US Sprint. This incident has been resolved.
Posted Jun 16, 2020 - 14:02 PDT
Monitoring
We have started seeing recovery for SMS from a subset of Twilio Short Codes to US Sprint. We will continue to monitor to ensure a full recovery.
Posted Jun 16, 2020 - 12:09 PDT
Update
We are continuing to work with our carrier partner to resolve the issue with SMS Delivery Delays from Subset of Twilio Short Codes to US Sprint. We will provide further updates as more information becomes available.
Posted Jun 16, 2020 - 09:32 PDT
Update
We are continuing to work with our carrier partner to resolve the issue with SMS Delivery Delays from Subset of Twilio Short Codes to US Sprint. We will provide further updates as more information becomes available.
Posted Jun 16, 2020 - 07:55 PDT
Update
We are experiencing SMS delivery delays when sending messages to US Sprint from a subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 16, 2020 - 06:48 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 16, 2020 - 06:41 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America, MMS Short Code, North America) and PROGRAMMABLE MESSAGING (MMS, SMS).