Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Call failures on a subset of French and Dutch numbers
Incident Report for Twilio
Resolved
All services are operating normally
Posted 11 months ago. Feb 11, 2018 - 16:29 PST
Monitoring
Calls on the affected French and Dutch numbers are working normally. We continue to monitor
Posted 11 months ago. Feb 11, 2018 - 15:45 PST
Identified
We continue to work with our carrier partner to resolve the issue.
Posted 11 months ago. Feb 11, 2018 - 09:36 PST
Investigating
We are investigating failures on inbound calls to a subset of French and Dutch numbers. We are working to resolve the underlying issue with our carrier partner.
Posted 11 months ago. Feb 11, 2018 - 05:46 PST
This incident affected: PROGRAMMABLE VOICE (PSTN).