We're continuing to experience SMS delivery delays from Twilio toll-free numbers in the US. Since we're also experiencing SMS delivery delays from Twilio toll-free numbers in CA, we'll resolve this post and continue to give updates for both regions at https://status.twilio.com/incidents/10b1syzpl0xp.
Posted Nov 24, 2023 - 11:23 PST
Investigating
Due to sustained high traffic on the US carrier networks, we are currently experiencing SMS delivery delays from Twilio toll-free numbers. Messages are queued due to capacity shortage, and customers may see delays when sending to certain US carriers. Please find the current delivery status for the major carriers below:
We are actively working with our carrier partners to resolve the issue, and we will provide another update in 2 hours or as soon as we have any new information to share.
Posted Nov 24, 2023 - 09:21 PST
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).